Cash deposits aren’t working for some members right now.

Incident Report for Tide

Resolved

Cash deposits are available again

Some members experienced problems depositing cash, but this has now been sorted.

Thanks for giving us the time to fix this - now you should be able to deposit cash as usual.
Posted Feb 25, 2026 - 17:59 GMT

Identified

We’re investigating the issue - check back here for updates.

Thanks for your patience, and sorry for any inconvenience.

For anything urgent, tap ‘Support’ in the app.
Posted Feb 25, 2026 - 17:06 GMT