Issue with viewing Statements and Account Verification Letters in the mobile app.

Incident Report for Tide

Resolved

This incident has been resolved.
Posted Apr 04, 2024 - 13:47 BST

Update

The issue was fixed!
Please update the app to the latest version - this should fix any problems that where previously observed.
Posted Apr 04, 2024 - 13:47 BST

Update

We are continuing to work on a fix for this issue.
Posted Apr 02, 2024 - 17:47 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 02, 2024 - 15:46 BST

Investigating

The issue affects the mobile app only. Members should still be able to view statement by using the web browser version of the app.
Posted Apr 02, 2024 - 13:30 BST
This incident affected: UK Tide App.