We've resolved the issue that was affecting inbound payments and outbound payments. Payments are now running as usual.
Thanks for your patience while we sorted this out.
If you have any queries, tap 'Support' in the app and we'll help you.
Posted Feb 27, 2026 - 19:26 GMT
Identified
Update: Payment services issue
New inbound and outbound payments are currently going through normally.
We're looking into inbound payments that are still not showing on members’ timelines and outbound payments that still appear as ‘Pending’.
We're sorry for any inconvenience.
For urgent queries, tap 'Support' in the app and we'll help you
Posted Feb 27, 2026 - 11:05 GMT
Investigating
We’re experiencing an outage affecting some of our services.
Some inbound payments aren’t showing on members’ timelines – they’re held in a queue, and will appear when the issue is resolved.
Some outbound payments are successfully being debited from members’ accounts, but are showing as pending and are currently held in a queue. They will be received by the recipient once this is resolved.
Please don’t repeat any payments for the time being.
We’re very sorry for the disruption, and we’ll keep you updated on this page.