Inbound payments delay

Incident Report for Tide

Resolved

Inbound payments were slightly delayed, but are now going through normally.

Thanks for giving us the time to resolve this.
Posted Jun 08, 2026 - 14:24 BST

Investigating

We’re experiencing an issue with inbound payments - they're being queued and will go through with a slight delay.

We’re fixing this as quickly as we can -- apologies for any inconvenience.

If you have any questions, tap ‘Support’ in the app.
Posted Jun 08, 2026 - 09:37 BST