Member support chat and phone lines unavailable

Incident Report for Tide

Resolved

The issue is resolved and all support line are available as normal again!
Posted Aug 29, 2025 - 19:03 BST

Identified

The support chat and phone lines are currently not working as they should.

We will update here as soon as they are available again!
Posted Aug 29, 2025 - 18:53 BST