Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 31, 2024 - 22:00 GMT
Scheduled
EUR SEPA payments will be unavailable from 22:00 GMT on 31 December 2024 until 18:00 GMT on 1 January 2025. For urgent queries, tap ‘Support’ in the app. We apologise for any inconvenience.
Posted Dec 27, 2024 - 11:57 GMT
This scheduled maintenance affected: Making Payments (UK).