EUR & USD payments unavailable

Incident Report for Tide

Resolved

Everything should be working as normal again and you can make international payments.
Posted Aug 30, 2025 - 10:59 BST

Identified

We’re experiencing issues with outbound EUR & USD payments from the app.

You may use Tide on the web to make any urgent international payments until we have fixed this issue.

For urgent queries, tap ‘Support’ in the app.
We apologise for any inconvenience.
Posted Aug 30, 2025 - 08:25 BST