Delays on timeline updates
Incident Report for Tide
Resolved
All payments both in and out should now be showing on the in app timeline again!
Posted May 31, 2023 - 13:48 BST
Update
We are estimating that all delays will be caught up by approximiately 13:15.

Most Tide members that where affected should already see their transactions on their respective timelines
Posted May 31, 2023 - 12:38 BST
Identified
Some Members are experiencing delays in payments in and out appearing on their account timelines. Payments have been processed successfully, there are just some delays in updating the latest balance.

Please do not attempt to resend or request payments again as they have already been processed. We will advise here as soon as the messaging has caught up.

We apologise for any inconvenience this may cause you in the interim.
Posted May 31, 2023 - 07:58 BST
This incident affected: UK Tide App, UK Tide on the Web, and Making Payments (UK).