Payments and timelines
Incident Report for Tide
Resolved
Payments are now successfully processing and the timeline information has been updated.

The issue was detected at 20:15 and fixed by 21:35.

Tide apologise for this interruption to your service this evening.
Posted Nov 22, 2021 - 22:03 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2021 - 21:51 GMT
Identified
We are aware and investigating an issue affecting:
- Making payments
- Up to date account timeline information
- New account creation

We apologise for this interruption and are working to bring this back as quickly as possible.
Posted Nov 22, 2021 - 21:40 GMT
This incident affected: Tide on the Web, New Member Sign-up, Making Payments, and Tide App.