Degraded Performance - Tide

Incident Report for Tide

Resolved

We have now restored the Tide service. You should now be able to login and use Tide as usual.

We apologise for this impact on your Tide experience, thank you for your patience.
Posted Jun 18, 2022 - 11:58 BST

Investigating

We're experiencing an issue affecting our Tide platform.

You may be experiencing problems using the application.

We are currently looking into the issue.
Posted Jun 18, 2022 - 11:48 BST