Error
Incident Report for Tide
Resolved
This incident has been resolved.
Posted Nov 09, 2023 - 10:48 GMT
Investigating
You may not be able to upgrade or switch your membership plan at the moment.
We’re investigating why this is happening, and we apologise for any inconvenience.
Tap ‘Support’ in your app if you require urgent help relating to this issue.
Posted Nov 09, 2023 - 09:37 GMT
This incident affected: UK Tide App.