Transaction timeline not loading

Incident Report for Tide

Resolved

We’re back to normal and you can now see your timeline of transactions again.

Thank you for giving us the time to resolve this – we appreciate your patience.

Once again, we apologise for any inconvenience this may have caused.
Posted Aug 28, 2025 - 10:23 BST

Identified

Some members may not be able to see their transaction timelines for a while.

Inbound and Outbound payments are running normally.

We're fixing this

Once the issue is resolved, we’ll let you know here immediately.

We're sorry for the inconvenience.

Tap the 'Support' in the upper-right of your app if there's anything urgent.
Posted Aug 28, 2025 - 10:03 BST