Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 17, 2024 - 22:50 BST
Scheduled
All Faster payments sent out of the account will be queued until after this maintenance window. You may also see delays to incoming payments during this time.
If your payment hasn’t arrived after the maintenance window, tap ‘Support’ in your app to contact us.
Posted Aug 16, 2024 - 10:25 BST
This scheduled maintenance affected: Making Payments (UK).