Issue: Delays in onboarding and account recovery

Incident Report for Tide

Resolved

Resolved: Onboarding and account recovery

All services are working as expected

An earlier issue may have prevented you from:

Opening a new account

Recovering your account

We resolved this as quickly as possible and you can do all of the above as usual.

We're sorry for the disruption.

If you need any further help, tap ‘Support’ in the app.
Posted Apr 16, 2026 - 14:02 BST

Identified

We’re experiencing a problem that’s impacting a number of our services including:

Onboarding new accounts

Recovering accounts

We'll notify you in your app to let you know if we've got you on board and when you can continue with recovering your account.

Apologies for the inconvenience.

For urgent queries, tap 'Support' in your app and we'll help you.
Posted Apr 16, 2026 - 12:59 BST