Digital cheque deposits are failing

Incident Report for Tide

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 12:20 BST

Investigating

We're experiencing an issue which is preventing some members from depositing cheques.

If your cheque deposit has failed, you can try to resubmit it.

We're already on it and will keep you updated on this page.

If you need any help - tap ‘Support’ in the app.

We're sorry for any inconvenience.
Posted Sep 18, 2026 - 11:16 BST