Payments delay

Incident Report for Tide

Resolved

Resolved: Payments delay

Payments were delayed, but are now going through normally.

Thanks for giving us the time to resolve this.
Posted Sep 25, 2026 - 13:59 BST

Investigating

We’re experiencing an issue with payments - they're being queued and will go through with a delay.

If you’ve made a payment and it’s not showing on your timeline, please don't repeat it.

We’re fixing this as quickly as we can -- apologies for any inconvenience.

If you have any questions, tap ‘Support’ in the app.
Posted Sep 25, 2026 - 13:22 BST