Error: Phone support
Incident Report for Tide
Resolved
This incident has been resolved.
Posted Jul 05, 2024 - 17:58 BST
Monitoring
A resolution has been implemented, and we are monitoring the results.
Posted Jul 05, 2024 - 16:34 BST
Investigating
We’ve encountered a technical problem: members are currently unable to hear us over the phone.

We’re fixing this.

For urgent queries, tap ‘Support’ in your app to open a chat with us.
Posted Jul 05, 2024 - 15:06 BST
This incident affected: Member Support (UK).