Resolved: Direct Debits delay

Incident Report for Tide

Resolved

Earlier delays with Direct Debits have been resolved, and transactions are running normally.

Thanks for giving us the time to resolve this.
Posted Feb 05, 2026 - 13:05 GMT