Error: Incorrect balance display
Incident Report for Tide
Resolved
We completed the fixes and you should see the correct balance on your app again as normal!

We appreciate your patience while we dealt with the matter.
Posted Sep 13, 2024 - 10:04 BST
Identified
What’s happening:
Some members see incorrect balances in the Tide app and on Tide on the web.

We’re fixing this.

We’re sorry for the inconvenience and we’ll update this page when we’ve resolved the issue.

If you need to speak to us, tap ‘Support’ in the app.
Posted Sep 12, 2024 - 08:56 BST
This incident affected: UK Tide App, UK Tide on the Web, and Making Payments (UK).