Degraded performance - Member Support
Incident Report for Tide
Resolved
We have now restored the New Member Signup process. You should now be able to create a new account with Tide.

We apologise for this impact on your Tide experience, thank you for your patience.
Posted Apr 20, 2021 - 13:38 BST
Investigating
We're experiencing an elevated level of errors affecting our Member Support function.

You may be experiencing a degraded performance.

We are currently looking into the issue.
Posted Apr 20, 2021 - 13:32 BST
This incident affected: Member Support (UK).