Degraded Performance - Tide
Incident Report for Tide
Resolved
We have now restored the Tide service. You should now be able to login and use Tide as usual.

We apologise for this impact on your Tide experience, thank you for your patience.
Posted Apr 30, 2021 - 09:57 BST
Investigating
We're experiencing an issue affecting our Tide platform.

You may be experiencing problems using the application.

We are currently looking into the issue.
Posted Apr 30, 2021 - 09:52 BST
This incident affected: Tide App and Tide on the Web.