New account creation failing
Incident Report for Tide
Resolved
This issue has now been resolved.

Tide apologise for any inconvenience this has caused anyone.
Posted May 09, 2022 - 18:58 BST
Update
A fix was implemented and we are monitoring the results.
Posted May 09, 2022 - 18:26 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 09, 2022 - 18:21 BST
Identified
The root cause of the issue was identified and work on a fix has begun.
Posted May 09, 2022 - 17:15 BST
Investigating
New account creation is failing. The incident team is investigating.
Posted May 09, 2022 - 15:12 BST
This incident affected: New Member Sign-up (UK).