Payment OUT delays affecting some Members
Incident Report for Tide
Resolved
We have applied a fix and all transactions are now flowing.

We apologise to any Members who were affected by this interruption.
Posted Nov 26, 2021 - 18:49 GMT
Investigating
We are are of an issue affecting some Members making Payments from their tide accounts. We are investigating the cause.

Payments are currently queued, there is no need to re-submit them if you believe that you are affected.

We apologise for the current delay in processing these payments.
Posted Nov 26, 2021 - 17:03 GMT
This incident affected: Making Payments (UK).