Payments issues - Cards and Faster Payments
Incident Report for Tide
Resolved
We have been monitoring the situation for 24 hours and we are now confident that the problem has been resolved.

If you believe that you are still experiencing a problem, please reach out to our Member Support team in the usual manner.

Thank you for you patience. Tide apologises for the inconvenience this will have caused.
Posted May 11, 2022 - 12:05 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 10, 2022 - 12:30 BST
Identified
We apologise for the on-going issues when making payments both with your cards and within the app.
We are making a change and hope to see an improvement shortly.
Posted May 10, 2022 - 10:28 BST
Investigating
We understand there are reports of a possible re-occurrence of yesterdays issue affecting Payment types.

The team are investigating as a matter of urgency.
Posted May 10, 2022 - 09:06 BST
This incident affected: Making Payments (UK).